
Analysis: Epi Graph 
S U M M A R Y  

This lesson is an introduction to the Epi Graph module of Analysis. In this lesson, you will 
create and customize several types of graphs using the survey data including, bar, pie, and line. 
You will also export a graph as an image. Results created in Epi Graph can be used in reports 
later to present your findings as graphic representations. 

Based on the survey data, many types of graphs could be produced to illustrate the need for 
funding. In this lesson, you will create graphs to illustrate age groups, missed days by gender, 
and the worst month for asthmatic conditions by school. For the asthma funding report, you 
will be creating a pie chart to illustrate which month is the worst month for asthmatic 
conditions based on data from the children surveyed. 

You must have the Lesson5.PGM open and run prior to completing this lesson, as the code 
created in the previous lesson affects these graphs. 

Length of time to complete: 2 hours Beginner 

Graph Types 

Overview of the types of graphs created in this lesson and how to use the GRAPH dialog 
box to make graph type selections. 

Create a Bar Graph 

Use the GRAPH command to create a bar graph for the Age variable. 

Create a Pie Graph 

Use the GRAPH command and the Customization dialog box to create a Pie Graph of the 
worst month for asthma. This graph will be exported and used in Lesson 10 Epi Report. 

Export a Graph 

Use Epi Graph to export a graph as an image for use in later reports and presentations. 

Create a Rotated Bar Graph 

Use the GRAPH command to create a rotated bar graph of missed days of school by gender. 

Plot a New Graph Type 

Use the Customization dialog box to change a bar graph into a line graph. 

Lesson 6 



Create a Stacked Bar Graph 

Use the GRAPH command to create a stacked bar graph of the worst month for asthmatic 
conditions by surveyed school. 

Skills Review 

Series of five review questions based on the reading and hands-on activities in this lesson. 

B E F O R E  Y O U  B E G I N   

Complete Lesson 4 Analysis: Basics. 

Complete Lesson 5 Analysis: Creating Statistics. 

W H A T  Y O U  N E E D   

Asthma Survey 2005.MDB 

Lesson 5.PGM 

F I V E  G O A L S  

 Create a bar graph containing the ages of the children in the survey population. 

 Create a pie graph of the worst month for asthmatic conditions and export it to be used 
in a later lesson. 

 Create a rotated bar graph of missed days of school by gender. 

 Create a stacked bar graph of worst month for asthmatic conditions by school. 

 Use the Customization dialog box to plot new graph types and edit your graphs once 
created. 
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Graph Types 
From the Analysis module, you will use the GRAPH command to create graphical 
representations of your data. From the Graph dialog box, you will select a Graph Type, an X-
Axis variable, a Y-Axis variable, and a Series variable by using the corresponding drop-down 
boxes.  

 

The following graph types will be created in this lesson: 

BAR 

Bar Graphs are used to group data together according to categories and display a bar for each 
value in that category. Bar lengths represent quantities in a set of data. Bars are color-coded 
according to the series represented and displayed vertically. 

ROTATED BAR 

Rotated Bar Graphs are bar graphs with horizontal bars representing the count or weight of 
each value of the main variable(s).   

STACKED BAR 

Stacked Bar Graphs are created in the same manner as non-stacked bar graphs, except that 
the Y values from each series accumulates. Bars are stacked on the end of the previous bar 
with each separate series color-coded. 
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AREA 

Area Graphs display data sets on X-Y axis with the area under the line filled.  

SPLINE 

Spline Graphs have values indicated by points connected with a smooth curve.  

POINT 

Point graphs contain data indicated by a marker for each data point.  

LINE 

Line graphs are used to determine trends and cyclic variation based on interaction of data 
elements. Data points are plotted on the graph and connected with lines. Line graphs can 
display large amounts of data that varies along some accepted sequence such as time, 
temperature, price etc. Line graphs with multiple lines can be used to display several variables 
to conserve space and to facilitate comparison of more than one dependent variable on a 
single independent scale. Line graphs must have numeric variables for both X and Y-axes and 
the X variable values are treated as continuous. To generate a line graph utilizing categorical X 
variables, use the Bar graph command and then customize the graph style to Line.  

PIE 

A pie graph is a circular graph used for proportional assessment by comparing data elements 
such as percentages or counts against other data elements and against the sum of the data 
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You must have the Lesson5.PGM open and run prior to completing this 
lesson, as the code created in the previous lesson affects these graphs. 

Create a Bar Graph 
Use bar graphs to make comparisons of single events and the differences between them. To 
visually present the age distribution of the survey population, you will create a bar graph of 
the Age variable. 

1. From the Command Tree Statistics folder, click Graph. The Graph dialog box opens. 

 

 The default graph selection is Bar. 

2. From the Main Variable drop-down menu, select the X-Axis value of Age. 

3. Click OK. Epi Graph opens.  

 You may need to click the flashing Epi Graph icon from the task bar. 

4. View the bar graph.  

 Be sure that the Age field is calculated for all records. If you have READ in a new file 
or program or closed Analysis, then you will have to calculate the Age values. Age 
fields should be coded, if you have the Lesson5.PGM open and run from the 
Program Editor. 
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5. Click the Close X. The bar graph is now embedded in the Output window and part of 
your output file. 

Your graph should look like the following: 
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Create and Customize a Pie Graph 
Create a Pie graph that illustrates the worst month for asthmatic conditions. In the survey 
parents were asked which month presented the most breathing problems for their child based 
on their symptoms. To illustrate your findings, you will create a pie graph on the WMonth 
variable.  

1. Click Graph. The Graph dialog box opens. 

2. From the Graph Type drop-down, select Pie. 

3. From the Main Variable drop-down, select WMonth. 

4. Click OK. The WMonth Pie Graph appears. 

5. From the main navigation bar, select View>Customization, or use your mouse to right 
click inside the graph and select Customization Dialog from the pop-up menu. The 
Customization dialog box opens. 

 

 Each tab inside the Customization dialog box allows you to change a part of your 
graph and how it is viewed on the page. 

6. From the General tab, in the Main Title field, type Worst Month for Asthmatic Conditions. 

7. Delete the text Wmonth from the SubTitle field. 

8. Select the 3D radio button. 

9. Click Apply. The graph updates. 
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10. Click the Font tab. 

11. Select a new font for your title. 

12. Make the title Bold. 

13. Click Apply. The title font updates. 

14. Click OK to close the Customization dialog box. 

15. From your graph, left click on the number 9. The Point Label dialog box opens. 

 

16. Type the month name September and click Ok. 

17. Name each Point Label for the month with which it corresponds. 

 Your pie graph should look similar to the following: 
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Export a Graph 
Now you are going to Export the WMonth pie graph for use in another program. Graphs can 
be exported for use in other programs such as MS Word, PowerPoint, or Epi Report. You 
will be using the WMonth pie graph in Lesson 10 Epi Report when you create your asthma 
initiative report. 

1. From the Epi Graph main navigation menu, select File>Export. The Exporting dialog 
box opens. 

 

2. From the Export section, select BMP to create a bitmap file. 

3. From Export Destination, select File.  

4. Click Browse. The Save As dialog box opens. 

5. Locate the EIHA Tutorial folder. Name your file WMonthPieGraph. 

6. Click Save.  

7. From the Exporting dialog box, click Export. 

8. Close Epi Graph. 

 You will use the exported graph in the Epi Report lesson. 
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Create a Rotated Bar Graph 
In this section, you want to illustrate the number of missed days of school by gender. This will 
help in determining whether there is a difference in how much school is missed based on the 
gender of the survey population. 

1. Click Graph. The GRAPH dialog box opens. 

2. From the Graph Type drop-down menu, select Rotated Bar.  

3. For the Main Variable drop-down, select MissDays. 

4. From the SERIES Bar for each Value of drop-down, select Gender. 

5. Click OK. Epi Graph opens. 

 Your Rotated Bar graph should look similar to this example: 

 

6. From the Epi Graph navigation bar, select View>Customization. The Customization 
dialog box opens. 

7. From the General tab, type the Main Title Missed Days by Gender. 

8. From the General tab, select the Font Size Small radio button. 

9. From the General tab in the Grid Lines section, select Y. 
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10. Click Apply. 

11. Click OK. Do not close Epi Graph. 
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Plot a New Graph Type 
You can change a bar graph with categorical X values into a line graph by using the 
Customization dialog box. You are going to use the rotated bar graph from the previous 
lesson and view it in a different format. 

1. From the Epi Graph navigation bar, select View>Customization. The Customization 
dialog box opens. 

2. Click the Plot tab.  

3. From the Plot Style selection, select Line. 

4. Select the Mark Data Points check box. 

5. Click Apply. The rotated bar information is transformed into a line graph. 

 

6. Click the Points tab, select the Point Label Orientation, Slanted. 

7. Click Apply. 

8. Click the Style tab. 

9. Select Female and from the Point Type drop-down, select the solid diamond. 

10. Select Male and from the Line Type drop-down, select the small blue dotted line type.  
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11. Click the Burgundy color box. 

12. Click Apply. 

13. Click OK. 

14. Close Epi Graph. 
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Create a Stacked Bar 
To determine if one school had more students with breathing problems in any given month 
than the others, you can create a stacked bar of the WMonth variable with a series bar for 
each value of SchoolNum. This will show you, for example, that School A did not have any 
students who answered that their worst breathing month was December. 

1. Click Graph. 

2. From the Graph Type drop-down, select Stacked Bar. 

3. From the Main Variable drop-down, select WMonth. 

4. From the SERIES Bar for Each Value, select SchoolNum. 

5. Click OK. Epi Graph opens. Notice that the months are not in sequence by month, but 
by the first digit of the number. In Lesson 7 Exporting Files, you will use the RECODE 
command to re-order the months to appear in the proper sequence. 

Your stacked bar graph should look similar to the following: 

 

6. Right click the graph and select Customization Dialog from the pop-up menu. 

7. Click the Plot tab. 

8. From the Plot Style section, select Points and Spline. 



L E S S O N  6  

15 

9. Click Apply. 

10. Click OK. 

 The same worst month information is now presented in a Points and Spline format. 

 

11. Right click the graph and select Customization Dialog from the pop-up menu.  

12. Click the Plot tab. 

13. Select Area Stacked. 

14. Click Apply. 

15. Click OK. 

 The same worst month information is now presented in an Area graph format. 

16. Close Epi Graph. 
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 Skills Review 
Place a checkmark next to the correct answer for each of the following questions. Refer to 
Appendix D Skills Reviews Answer Key  for further details. 

1. You can use a Line Graph to determine trends and cyclic variation. 

True 

False 

2. Which type of graph presents a circular proportional assessment by comparing data 
elements such as percentages or counts against the sum of the data elements? 

Line Graph 

Bar Graph 

Pie Graph 

3. From Epi Graph, select the two ways you can open the Customization dialog box. 

Right click and select Customization Dialog from the pop-up menu 

Select View>Customization 

It automatically opens 

4. Graphs can be exported for use in other programs, such as MS Word, PowerPoint, or 
Epi Report. 

True 

False 

5. You can plot a new graph type from an existing graph using the Customization dialog 
box. 

True 

False 
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Lesson Complete! 

 

W H A T  Y O U  L E A R N E D  

How to 

 Create a Bar, Pie, Rotated Bar, and Stacked Bar Graph to illustrate statistical findings. 

 Export a Graph for use in another program or for a presentation. 

 Use the Epi Graph Customization dialog box to create graphs specific for your 
project or plot a new graph type. 

 


