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Enter Data  
S U M M A R Y  

This lesson is an introduction to entering data from the Make View and Enter Data modules 
of Epi Info™. In this lesson, you will learn how to enter data, navigate the survey you created 
in Make View, and enter data for the sample survey provided. You will also learn how to 
search for records from the Enter module. When you enter records in the survey, you are 
populating the data table with information that will be used for later analyses. 

In Lesson 1, you created an electronic version of the survey you will use to collect data to aid 
in your asthma initiative project. In Lesson 2, you added Check Code to your survey to speed 
the data entry process and to act as a quality control measure. In Lesson 3, you will begin 
entering data about the students from the survey population. Data entered in this lesson will 
be used to create statistics and develop a picture of the student body of the county for which 
you are trying to get funds. 

Time to complete: 1 hour Beginner 

Getting Started with Enter Data 

Overview of basic information to navigate the Enter Data module. 

Enter Data to the Survey 

Use the record information provided to enter data into the View you created. Verify your 
Check Code works as intended. 

Enter Data to the Sample Survey 

Gives you the opportunity to view a complete survey with existing records. Enter data from 
the surveys in Appendix C.    

Find Records  

Introduction to the Find feature. Practice lesson included. 

Skills Review 

Series of five review questions, based on the reading and hands-on activities in this lesson. 

B E F O R E  Y O U  B E G I N   

Complete Lesson 1 Make View: Create a Survey. 

Lesson 3 
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Complete Lesson 2 Make View: Check Code. 

Download the sample project Asthma Survey 2005. 

W H A T  Y O U  N E E D  

Asthma Survey.MDB- This is the project you created in Lessons 1 and 2. 

Asthma Survey 2005.MDB- This is the provided dataset used in this Lesson and Lesson 4.  

Appendix C Sample Parent School Asthma Pre-Intervention Surveys 

Appendix D Skills Reviews Answer Key 

F I V E  G O A L S  

 Learn to navigate the Enter Data module. 

 Enter 4 records in the View you created. 

 Verify that the data entry conditions and Check Code functions. 

 Troubleshoot your Check Code, if there are errors. 

 Enter 2 records in the sample View and Data table provided. The sample view and data 
table Asthma Survey 2005.MDB will be used in Lessons 4-10. 
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Getting Started with Enter 
The Enter Data module can be accessed by clicking Enter Data from the Epi Info™ main 
page. You can also access Enter Data through the Make View module by selecting 
File>Enter Data. Use the Enter Data module to enter information into the survey/view you 
created in Make View. When you enter data into the view, you are populating the data table 
inside your project (.mdb). You can navigate from Make View to Enter to test your Check 
Code and Tab Order, but once you create a data table and start adding data, you cannot make 
changes to field names or types in your view. 

The Enter program displays the View you created in Make View, constructs your data table, 
and controls the data entry process by using the settings and Check Code established in Make 
View. From the Enter Data module, you will enter new data, modify existing data, or search 
for records. The Find function allows records to be located based on a series of matched 
variables. As you enter data, the cursor moves from field to field, page to page, and saves data. 
Navigation is provided for New, Next, Previous, First, and Last records and through related 
tables. 
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The Enter Data Workspace 
If you do not have the project Asthma Survey.MDB that was created in Lesson 1 and 2, you 
can use the provided project titled Asthma Survey 2005.MDB. Use this project for a reference 
as you read the navigation sections and then skip to Section 3: Enter Data in the Sample 
Survey. 

1. From the Epi Info™ main page, click Enter Data. The Enter window opens. 

2. Select File>Open.  

3. Open the project you created in Make View titled AsthmaSurvey. The Select a 
Table dialog box opens.   

4. Select the View PreInterventionSurvey. 

5. Click OK. The Data Table dialog box opens.  

6. Click OK to create a New Data Table. The New Data Table dialog box opens. 

7. Click OK to keep the Data Table Name and Unique ID set as the default. The 
Enter page opens with the view you made in Make View. 

 Notice you are in Record 1 of 1 on Page 1 titled Personal Information. 

 The Enter Page Panel displays a list of pages created in the project. Data entered into 
a page is automatically saved; however, you should use the Save Data button or 
File>Save after making changes to existing records. 
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This is an example of the Enter Data workspace. The top of the page shows you are in the 
Enter module. 

 

 

Navigating Enter Data 

You cannot navigate through pages until data has been entered in the preceeding page or until 
all required fields are filled. You can familiarize yourself with the workspace prior to adding 
records. Keep the Enter module open to complete the next lesson. 

Enter Data Main Page 

File 

Use the File menu to open, close, save, print, or exit. You can also compact your database 
with the compact utility. This reduces the size of your database but does not affect your data. 

Edit 

Use the Edit menu to Find specific records or to delete records. Deletion removes the current 
record from the project, and all records associated with it. It also marks the record as deleted 

This is an example of the Enter main page. The left hand pane 
shows that you are in the Enter module of Epi Info™ and are on 
Page 1 called Personal Information. 
 
The cursor is sitting in the Student ID # field where you created a 
Code Table. Notice in the bottom left hand section of the screen, 
the words Must Enter. When you tab to fields that contain Check 
Code, the text in the left hand corner changes. For example, a 
Required field will read Must Enter when you tab to it.  
 
 

This is an example of the Enter Data 
Page Panel 
 
Notice that you can navigate entered 
records by using the arrow buttons 
at the bottom of the page. You are in 
Record 1 of 1. 
 
You can enter a new record by 
clicking the New button or tabbing 
through the record to the end of the 
available fields. 
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in the database. You can exclude deleted records from your analyses. Click Undelete to 
return the record to active status. 

Options 

Use the Options Menu to select the values of Yes/No variables. Variables can appear as 
Yes/No or True/False. From Options, you can also maximize the size of your screen image 
by selecting Full Screen. 

Help 

Use the Help Menu to view the online help. 

Enter Data Page Panel 

Use the Page Panel to navigate pages in your View. If you are entering data and have a 
required field, you must enter information into that field before proceeding to the next page. 
From the Enter Page Panel you can go to the next record, save data, delete a record, find a 
record, or create a new record. 

Use the navigation arrows at the bottom of the Enter Page Panel to move between records. 
Single arrows move you one record forward or backward. Double arrows move you to the 
first or last record.  

 

Type a specific record number in the Record field and press Enter to go directly to a record. 
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Enter Data into your View  
Begin entering the four student records listed in the table on the following page. Tab through 
each field to run the Check Code and to navigate through the survey. If you do not tab 
through the survey, your check code will not run. 

1. Verify that your Check Codes are functioning.  

 Is the Code Table you created between the variables for School Number and PS 
School Number functioning? 

 Did the Age field populate after you tabbed out of the Date of Birth Field? 

 If your answer to Missed Sports is No, is the Number of Times variable skipped? Did 
the cursor go to the following question? If the answer is Yes, did the cursor go to the 
Number of Times variable? 

 Did the dialog box pop-up after you tabbed through the question regarding missed 
days? 

 After entering all the records, use the arrow keys to navigate between records and 
pages. Is the code functioning across records and pages?  

2. Select File>Save. 

 

Check Code Troubleshooting 

If your Check Code did not function, you can close the Enter module and return to 
Make View to verify the following. Use Lesson 2 on Check Code to verify your code 
appears as coded. 

 Verify your tab order. Coded fields must be in the proper order and on the 
proper page to function. For example, does the Age field come after the Date of 
Birth field in your tab order list? Are SpTimes and IllHome in the proper order? 
On the same page? 

 Did you Save all your Check Code in the Program Editor after it was created? 
Open the Program Editor and verify that there is an asterisk next to the variable. 

 Is your code applied to the correct field? Are your If/Then statements in the 
proper order?  

 Is your code syntax correct? You can verify this by placing the cursor inside the 
code and clicking Save. Did the code turn green or red? Red means you have an 
error in your code. 

 Do your commands have END statements?  
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Enter the following Student Records 

Refer to the section on Check Code Troubleshooting if your codes do not work. 

Student 1 Student 2 Student 3 Student 4 

School ID Number A School ID Number B School ID Number C School ID Number D 

Student ID Number 1 Student ID Number 2 Student ID Number 3 Student ID Number 4 

Zip 12207 12084 12077 12059 

Male Female Male Male 

01/29/1994 08/19/1995 11/08/1995 07/28/1994 

555-555-5555 444-444-4444 333-333-3333 222-222-2222 

Asthma, Wheezing No Conditions Asthma, Bronchitis RAD 

Yes, Medication No Yes, Medication Yes, Medication 

October N/A September July 

Wheeze 2 times each 
week 

Cough, 2 times each 
week 

Never Wheeze, 3 to 6 times 
each week 

Cough, Every day but 
not all day 

Wheeze, Never 

Cough, 2 times each 
week 

Missed 11 days Missed 0 days Missed 5 days Missed 3 days 

Yes, Missed sports, 1 
to 3 times a week 

No, Did not miss 
sports 

Yes, Missed sports, 2 
times a month 

No, Did not miss 
sports 

Asthma in home=1 Asthma in home=0 Asthma in home=2 Asthma in home=1 
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Enter Data into the Sample View  
If you are working with the Asthma Survey project you created in Lesson 1 and 2, you are 
going to change projects. The sample project contains an example of the entire survey created 
in Make View with ten records already entered. The sample project Asthma Survey 2005 is 
located in the EIHA Tutorial folder 

If you already have Asthma Survey 2005 open, skip to Step 7. 

You will be entering the data from the two attached surveys located in Appendix C. 

1. From the Enter Data menu, select File>Open. The Select a Table dialog box 
opens.  

2. Click Change Project. The Select a Project window opens. 

3. Locate the EIHA Tutorial folder and select the sample project Asthma Survey 
2005.  

4. Click Open. The Select a Table dialog box opens. 

5. Select the View PreInterventionSurvey. 

6. Click OK. The project opens to the next new record, which is number 11. The 
sample project contains ten previously entered records. 

7. Use the surveys from Appendix C Data Entry Surveys to add two additional records. 
You should have twelve records at the end of this lesson. 
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Find Records 
There are two ways to locate specific records in a large data table.  

1. From the Record field located on the Enter Page panel.  

 Type the number 3 into the Record number field.  

 Press Enter. Record 3 of 12 appears in the window. 

2. Click Find from the Enter Page panel. The Find Record window opens. 

 Use the Find feature to locate specific records in a large dataset to edit. 

 Select a variable to search, try Zip. An entry field appears. Enter the search criteria. 
For this example, enter 12207. Click OK or press Enter. 

 To open a Record from Find, double click the black arrow to the left of the results 
row. 

 Embedded text items in multiline and text fields can be found by searching for 
*word*. This type of search is called a Wild Card Search. In a Wild Card search, the 
asterisk is used to represent any letter or string of letters. For example, a search of 
last names as with the field ChildLast could look like *jo*. This search would pull 
names with the letters jo in the beginning or end of a word in the last name field, ie. 
Jones, Johnson, Johns, etc. 

 Dates and numeric fields can be searched using less than or greater than values (<>). 

 OR can be used search for matches based on more than one criteria. 

 ? can be used to search for a single unknown character. 

 Click Reset to clear the page and begin a new search. 
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 Practice 
Find the students who attend School A. 

Find the students who do not have bronchitis. Hint: Bronchitis NO. 

Find the students who missed more than 5 days of school. Hint: MissDays>5.  

Find the students who attend School A and have Asthma.  

Find the students whose last name begins with S. Hint: ChildLast S*.
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 Skills Review 
Place a checkmark in the correct answer for each of the questions below. Refer to Appendix 
D: Skills Review Question and Answer Sheet for further details. 

1. Once you create a  ____________  you cannot change field names or types in your view. 

Survey 

Data Table 

Legal Value 

2. What are the two ways you can enter a new record? Check all that apply. 

Tab through to the last record. 

Click New. 

Select the last available page. 

3. If you are entering data and have a required field, you must enter information into that 
field before proceeding to the next page. 

True 

False 

4. What expression could you enter in the Find feature to locate children who are greater 
than 6 in age? 

Age=6 

Age<6 

Age>6 

5. From the Find feature, what button do you click to clear the page and begin a new 
search? 

Start 

Reset 

Cancel  
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Lesson Complete! 

 

W H A T  Y O U  L E A R N E D  

How to 

 Navigate Enter Data. 

 Enter Records. 

 Change Projects. 

 Find records. 

 


